[Resolved] Elementor page settings for Full-Width

Home Support TotalPress Elementor page settings for Full-Width

This topic contains 4 replies, has 2 voices, and was last updated by  Donny Miner 2 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #74578

    Hey Thomas,

    I’m trying to set the pages to full-width to use with Elementor Pro and the options are not taking? Still displaying a box layout.

    I have tried setting the post/page [Page Builder Option] options to:

     Remove Content Area Padding
     Set Content Area to 100% Width

    Also, I tried settings the template to (Elementor Full-Width)

    #74699

    Thomas
    Founder/Lead Dev

    Hi Donny,

    I took a look and it seems I didn’t add some of the css. Totally my fault.

    I added to Primo and will be in the next update (coming very soon). You can add the css if you would like.

    Go to wp-content/plugins/tp-primo/assets/css/tp-primo-styles.css.

    At the very top you will see this: .maxed-out .site-content.grid-container {max-width: 100%;}

    replace that with this: .maxed-out .site-content.grid-container,.maxed-out .inside-content {max-width: 100%;}.

    This will set the main area to 100% width when you select Set Content Area to 100% Width.

    I thought it was added, but seems it got left out. Sorry for the inconvenience. Please let me know how it goes and like I mentioned earlier it will be in the next update.


    #74794

    Thanks Thomas… That worked!

    Do you know how to get rid of the top gab between the Nav-Bar area and content? Showing maybe a 30px margin?

    #74847

    Thomas
    Founder/Lead Dev

    Glad it worked.

    Yes, this setting is in the customizer: TotalPress Options > Content > Posts > Content Layout you will see the setting called Padding.

    This is where you can adjust the padding. You can also remove all the padding by using TotalPress Options > General > Layout > Container Layout – this is what the help icon will show you when you click on it:

    Select “Separate Containers” to keep a space between all elements in the content area such as, articles, widgets, footer and so on. Select “One Container” to have no spaces between any of the elements.

    Hope this helps.

    Again, I apologize for forgetting to add that.


    #74911

    Ha! The only place I didn’t look. I was looking at the page option…Only if I clicked the post option! LoL

    Thanks for all the help!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.